Student Forum

Welcome to the RIB support forum, designed for students to discuss technical issues about RIB software.

Please read the FAQ and your question may already be answered!

Student FAQ - Read First keyboard_arrow_right

General Discussion Unable to open (CostX Database is not running)

Viewing 6 reply threads
  • Author
    • #1781

      It can still be opened after I installed. But now I fail to open it & it pop out this message, saying CostX Database is not running.


      I tried to open my Services windows & select “Start” to “CostX Database”, then it shows this


      Then I restart “CostX Auth”, “CostX Core” & start “CostX Database” in Task Manager, but it still unable to start.


      So in this case shall I follow the step as shown in Student FAQ:

      “If you have done this and still get the unable to connect to the database error, then this may be due to a firewall or antivirus software assuming that iTWO costX® is a malware. In this case, you will need to either add the RIB program folder to the AV exclusions list, disable the AV scan and run iTWO costX® installer again to repair iTWO costX® services.”

      If yes, Is the RIB program folder means Exactal folder?

    • #1788

      Hi Pangxiyue,

      Thanks for your post.

      Yes, typically it should be in C:\Program Files\Exactal

      Hope this helps!


      iTWO costX Forum Admin

    • #1823

      Hi Pangiyue and Admin,

      I am having the same issue, even though i added “Exactal” to the exclusion list, I database issue is not solved.

      Can you please advise if yours is running fine? @ Pangxiyue? I got the screen below:


      Error message

    • #3547


      I’ve followed the steps exactly as the above remedy and the pop up still comes up for me. I ran repair and disabled AV.



    • #3550

      Hi Pangxiyue,

      Thank you for your post.

      Please can you send the logs from the Event Viewer so that we can help you further.


      iTWO costX Forum Admin

    • #6584
      Ye Fan

      I came across the same way! Is there any other way to solve it?I tried both methods and still can t run the database. Show error 1503

    • #6617

      Hi YeFan,

      Thanks for your post.
      We’ve passed your issue onto our IT Support team and will get back to you shortly.

      Thanks for your patience.


      iTWO costX Forum Admin

Viewing 6 reply threads
  • You must be logged in to reply to this topic.