Student Forum

Welcome to the RIB support forum, designed for students to discuss technical issues about RIB software.

Please read the FAQ and your question may already be answered!

Student FAQ - Read First keyboard_arrow_right

General Discussion Unable to Connect to Database

Viewing 4 reply threads
  • Author
    • #1726

      I attempt to open the CostX Standalone version and an error message pops up saying “Unable to connect to CostX database. Please ensure that this service is running and try again”. I have checked if the database is running in my Services application and it wasn’t running so I clicked “Start” and another error message popped up saying “Windows could not start the CostX database service on local computer”. I have also tried to apply for another serial number but that doesn’t work, it just results in the same error message

    • #1727

      Hi Carny,

      Thanks for posting on the student forum.

      We will email you shortly with a solution to try.

      Thank you.

      iTWO costX Forum Admin

    • #1728

      Hello I am having the same issue with the database.

      The only difference is that when i start the database with Services it says it wont stay open unless in use.

    • #1729

      Hi all,

      I am having the same issue as above.

      Once a solution is identified, can it please be posted below for other students currently experiencing the same issue?

      Thanks in advance.

    • #1730

      Hi all,

      Primarily, there are two common reasons for this error. Firstly, you should check if the iTWO costX Database service is running. Open your Services windows and scroll down to “iTWO costX Database” and check the Status. If it is not running, right click and select “Start”. If you have done this and still get the unable to connect to the database error, then this may be due to a firewall or antivirus software assuming that iTWO costX is a malware. In this case, you will need to either add the Exactal program folder to the AV exclusions list of disable the AV scan and run iTWO costX installer again to repair iTWO costX services.

      If this does not work, if you could try reinstalling iTWO costX (the same version) over the top of your current installation (without uninstalling anything) this should hopefully add the services back on the machine.

      If you have further questions, please feel free to contact

      Thank you.

      iTWO costX Forum Admin

Viewing 4 reply threads
  • You must be logged in to reply to this topic.