Student Forum

Welcome to the RIB support forum, designed for students to discuss technical issues about RIB software.

Please read the FAQ and your question may already be answered!

Student FAQ - Read First keyboard_arrow_right

General Discussion Measurement Display Issue

Viewing 3 reply threads
  • Author
    • #1339

      Hi everyone,

      I am new to CostX and successfully install the program.

      The training video is quite useful. However when I tried to follow the instruction to run CostX in my laptop, I found an issue as shown in the picture below. Whenever I wanted to measure a length or area, the measurement display is blank although it did measured the length.

      I spent my time searching online. However no such a similar issue was found so I found it might be some sort of system setting problem? Any ideas about how to solving the problem is appreciated.

      Best regards,

      William XU1

    • #1341
      RIB CostX

      Hi William,

      As for your question, please enable ‘Current Lin Info’ via CostX main menu => CostX options => Drawings => Show => Enable ‘Current Line Info’.

      Kind regards,

      Kristen Zhang

      • #1342

        Hi Kristen,

        Thanks for your help. However, after following your instructions, the issue is still there. And the ‘current line info’ was previously ticked as well. Is there other problem shooting method that I can try? I am really frustrated with this issue at the moment as seeing the measurement seems to be the most basic function for using the software.


    • #1350
      RIB CostX

      Hi William,


      Thank you for your post.


      We emailed you directly, please check your email associated with your account.


      Hope this helps!




      CostX Forum Admin

    • #8526

      Hello, I have the same issue as this. I have tried looking for a fix but each time, you guys email the person directly. Could you possibly post the fix to this on the forum? Thank you.

      • #8567
        RIB CostX

        “Hi Lawrence,

        You might have to contact your IT to perform the below steps.

        The symptoms of this issue are that the text in the measure distance tool (and other places) does not display, but instead you see an empty grey box. One cause may be another piece of software making changes to the fonts or font registry entries and not keeping them in sync. One main culprit that was found in the past was when someone upgrades from a previous version of MS Office (before 2016) to either Office 2016 or Office 365. What happens in this case is that Microsoft removes the “Arial Unicode MS” font from the file system but the registry entry is not removed. This causes an issue because uses the font information in the registry to find the fonts that are available on the system. If “Arial Unicode MS” exists, we will usually try to use this font.

        To verify if the “Arial Unicode MS” font is on the system, you can do the following steps (assuming the user has installed Windows in the standard location):

        Click the Start Button and type cmd.exe, then press enter. This should open a command console.
        If the command prompt does not start with C:, type C:, then press enter. This will make sure we are navigating the primary hard drive.
        Type cd \Windows\Fonts to navigate to the Windows  Font directory.
        Type dir arialuni.ttf and press enter.
        If the file exists, the command console should list the file with its creation date and file size (around 23MB). If the file does not exists the console will show “File Not Found” (see screenshot below).

        screenshot 1

        To verify if the font is in the registry, do the following steps:

        Click the Start Button and type regedit.exe and press enter. This will open the Windows Registry Editor.
        In the tree on the left navigate to the following path (in Windows      10 you can enter this path directly below the menu bar):
        Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts


        You should see a list of fonts that are registered on your machine.      Look for a font in the list called Arial Unicode MS (TrueType).
        This screenshot is from a test Windows 7 machine showing the Arial Unicode MS font in the list.

        Screenshot 2

        If  you do not have the Arial Unicode font on their machine, but the Arial Unicode font does exist in the registry you may delete the entry from the registry (right-click on the registry entry and press delete). If this is not the case, don’t change anything on the system as the issue is something different.

        Kind regards,

        CostX Forum Admin

Viewing 3 reply threads
  • You must be logged in to reply to this topic.