Student Forum

Welcome to the RIB support forum, designed for students to discuss technical issues about RIB software.

Please read the FAQ and your question may already be answered!

Student FAQ - Read First keyboard_arrow_right

Activation & Licensing Error on install

Viewing 5 reply threads
  • Author
    • #1343

      I’ve downloaded the exe file but every time I go to Run and install this program I run into this message:

      “Error! Can’t initialize plug-ins directory. Please try again later.”

      I’ve tried running my computer in soft boot mode to make sure no other software was an issue and still no result.

    • #1344

      Dear Nathpanas,

      Thanks for your post.

      Please confirm the size of the downloaded CostX file that you have there as if the file hasn’t completely been downloaded, you are likely to receive error messages.

      If you have any anti-virus applications running on the machine, please disable it while you try installing CostX.

      Hope this helps!


      CostX Forum Admin

    • #1443
      Yuewen Lu

      hi I’ve downloaded the exe file, but every time on half way of installation i got this message: “set up was unable to create the database within the database cluster successfully” and “Error on data writing to the connection: Invalid socket”. Also “Please try installing again”i tried to install it again but it’s still not working.

    • #1444

      Dear Yuewen,

      Thanks for your post.

      Please make sure Windows Update is up to date and restart PC after installed Window Updates;

      And tell us what antivirus software is running on his/her PC and if possible disable/uninstall it and try install CostX and see if it works;

      If you still has problem, we can jump on his/her machine to have a look

      Hope this helps!


      CostX Forum Admin


    • #1668


      I am also facing this problem when I was installing costx. I kept receiving the message “Setup was unable to upgrade the database cluster successfully. Please ensure you have administrator permissions and try installing again.”

      I followed your instruction for Yuwen to turn off the antivirus software before installing costx, but it still didn’t work.

      Can you please jump on my machine to have a look??

      Thank you so much!!

    • #1671

      Hi there,

      Thanks for posting on the student forum.

      In this case, you may need to completely uninstall the antivirus and try uninstalling and re-installing costX again. Please apply for a new serial number as each serial can only be activated once. Upon reinstalling the new costX, please try to run as administrator.

      If you encounter further issues, please contact

      Thank you.

      iTWO costX Forum Admin

Viewing 5 reply threads
  • You must be logged in to reply to this topic.