Student Forum

Welcome to the RIB support forum, designed for students to discuss technical issues about RIB software.

Please read the FAQ and your question may already be answered!

Student FAQ - Read First keyboard_arrow_right

Activation & Licensing Can't Run Database

Viewing 3 reply threads
  • Author
    • #1757


      Hi, it says here that the apps cannot run the database. Before this, I can use the CostX as usual. After a few days when I opened, this came up. So I’ve tried install and uninstall back but still the same even after I’ve deleted all the CostX data in my computer.

    • #1804

      Same situation here. How to resolve this?

    • #1805
      RIB CostX

      Hi jiaxie1,

      Thank you for your post.

      Primarily, there are two common reasons for this error. Firstly, you should check if the iTWO costX Database service is running. Open your Services windows and scroll down to “CostX Database” and check the Status. If it is not running, right click and select “Start”.

      If you have done this and still get the unable to connect to the database error, then this may be due to a firewall or antivirus software assuming that iTWO costX is a malware. In this case, you will need to either add the Exactal program folder to the AV exclusions list of disable the AV scan and run iTWO costX installer again to repair iTWO costX services.

      Hope this helps!


      iTWO costX Forum Admin

    • #1806


      But actually the problem I’m facing is like I showed down below. I am pretty sure that I have closed all the firewall and antivirus software and I tried to reopen my laptop but nothing changed. I don’t know what I should do now.

      Thanks for your help.

Viewing 3 reply threads
  • You must be logged in to reply to this topic.