Student Forum

Welcome to the RIB support forum, designed for students to discuss technical issues about RIB software.

Please read the FAQ and your question may already be answered!

Student FAQ - Read First keyboard_arrow_right

General Discussion Can not active CostX Core

Viewing 1 reply thread
  • Author
    • #7479

      Hi all, I hope someone can help me with this.

      I have been trying to fix this for a long time. After I installed the software and at the first launch, it showed:” The following services that iTWO costX requires are running but not responding to requests: CostX Core.”

      So I looked it up in the Services App and tried to activate it manually, but it doesn’t work. So I tried reinstalling the software and turning off AV & Firewall. Sometimes it becomes active, but after a few seconds, it will just turn off itself, and the software still does not work.  And other times, it shows that ”Windows can not active CostX Core service Error 1067” and doesn’t turn on.

    • #7480
      RIB CostX

      Hi YanzhiH,

      Thanks for your email.
      We’ve passed your issue onto our IT Support team and will get back to you shortly.

      Thanks for your patience.



      iTWO costX Forum Admin


Viewing 1 reply thread
  • You must be logged in to reply to this topic.